the rig is SICK!

Tech topics for MJ, XJ, KJ and KK models (SUV and Pick-Up) manufactured from 1984 to Present.
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

the rig is SICK!

Postby jjstasen » Sat Dec 29, 2012 5:51 pm

the rig sits for the most part. I let it run for about 45 minutes every friday, run it around the complex and such.

well today.... cranked it over, let it warm up, moved it about 100 yards and 0 oil pressure....

at idle the oil pressure is 20 or so PSI, hit the gas and 0 PSI.

i changed the oil pressure switch/sending unit. didn't help.

plenty of oil, not leaking oil, oil was changed about 3 months ago.

im not much of an engine guy, any suggestions on what it could be,

o-rings on pistons? head gasket? oil pump? flux capacitor?
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Sat Dec 29, 2012 6:37 pm

ok.... within the next month or so,

bank account willing.

im going to stick a mech gauge on it and see

(i dont think the dash gauge is wrong sounds like there is an angry squirrel in my block) :shock:
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
jayhawkclint
Posts: 301
Joined: Wed Jan 13, 2010 6:04 am
First Name: Clint
Last Name: Turner
Jeep Year: 1970
Jeep Model: CJ-5 (1954-1983)
Location: Moore

the rig is SICK!

Postby jayhawkclint » Sun Dec 30, 2012 5:50 am

If it is reading zero, don't wait to see what happens if the squirrels get uncaged.

Oil pump can be changed without removing engine. Pickup unit can possibly be accessed without hoisting block since you have a lift kit.
1970 CJ5
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Sun Dec 30, 2012 8:18 am

that was the plan...

mech gage, if still reads 0 new oil pump and go from there.
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
User avatar
soonermatt
Posts: 493
Joined: Mon Jan 17, 2011 2:00 pm
First Name: Matt
Last Name: Luttrell
Jeep Year: 1994
Jeep Model: YJ (1987–1995 Wrangler)

Re: the rig is SICK!

Postby soonermatt » Sun Dec 30, 2012 10:54 am

An old mechanic used to run the engine without the valve covers. Oil would get all over the place but you could tell what's going on. I guess in your case oil might not get all over the place.
*****************************************
Red Jeep
Shrek
Posts: 392
Joined: Thu Jan 12, 2012 6:39 pm
First Name: Danny
Last Name: Hubers
Jeep Year: 2012
Jeep Model: JK (2007–2019 Wrangler)
Location: noble

Re: the rig is SICK!

Postby Shrek » Sun Dec 30, 2012 6:30 pm

Sounds like a cam bearing. My mustang did the same thing. Motor will seam to less power & lifters will not stay pumped up. Cure... Rebuild!
2012 jku Rubicon, 3.5 metal cloak game changer lift, evo skids, 35" nitto trail grapplers.
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Wed Jan 02, 2013 12:58 pm

Shrek wrote:Cure... Rebuild!


that's what i'm afraid of, the motor has 89k on it, but i don't know how well it was taken care of.

ill let you all know when i get time/funds to start the diagnostics.
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
User avatar
desertratt
BOD
Posts: 1308
Joined: Tue Dec 15, 2009 4:06 pm
First Name: Scott
Last Name: Howard
Jeep Year: 1990
Jeep Model: YJ (1987–1995 Wrangler)
Location: Edmond, OK
Contact:

Re: the rig is SICK!

Postby desertratt » Wed Jan 02, 2013 2:09 pm

Is the 4.0 oil pump fed off the disturbitor like most engines? If so you can pull the distributor and hook a drill/extention/and appropriate bit to it and spin the oil pump. You'll be able to tell if the pump pumps by the drill bogging down a bit.
90 YJ, 60 front, 14b rear, sbc 327, t350, 203/205 doubler
N5SWH
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Thu Jan 03, 2013 9:04 am

ill have to look into that, thanks for the tip
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Fri Jan 04, 2013 12:51 pm

Well I have made a gut wrenching decision....

With the help of a friend I've decided to pull the motor and re-build it :twisted: .

It will give me time to look at the front locker and hubs, address some electrical issues, and get the rig running better than before.

SO-

I was planning on going on the Clayton run in April, and the WFTW '13 run in September.

If anyone wants a navigator/co-pilot/winch bitch/rock stacker for either of these runs, i'm your guy
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler

Return to “Compact Stuff”

Who is online

Users browsing this forum: No registered users and 1 guest