Little hot

Tech topics for MJ, XJ, KJ and KK models (SUV and Pick-Up) manufactured from 1984 to Present.
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: Little hot

Postby jjstasen » Fri Jun 29, 2012 9:30 pm

Thanks
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: Little hot

Postby jjstasen » Sun Jul 01, 2012 11:23 am

Thanks to the head technician from better late then never fabrication I got the water pump switched out. Thanks!
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
ghostrider
Posts: 18
Joined: Fri Oct 03, 2014 11:38 am
First Name: Don
Last Name: Gurley
Jeep Year: 2000
Jeep Model: XJ (1984–2001 Wagoneer/Cherokee)

Re: Little hot

Postby ghostrider » Mon Oct 06, 2014 1:53 pm

NO!!! Your engine should run no hotter than around 220. You may need to change the thermostat. I use a 220 in the winter and swap it to a 160 in the summer and warmer months. Or your thermostat may be stuck. I would start there since it's the cheaper first step. You can also try spinning the fan blade on the water pump. It it spins easy, then that may be the problem. Also, there should be a little WEEP HOLE on the bottom of the pump. If it's leaking there, then the pump is bad. Hope this helps.

Return to “Compact Stuff”

Who is online

Users browsing this forum: No registered users and 1 guest