the rig is SICK!

Tech topics for MJ, XJ, KJ and KK models (SUV and Pick-Up) manufactured from 1984 to Present.
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Mon Jan 07, 2013 7:35 pm

Holy oil pressure Batman!

I changed the oil in the red XJ and guess what happened??

No GD oil pressure!!!

It was perfect before I changed it.....

Screw it, taking it to a mechnic on Friday
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
rlpetty43
Posts: 550
Joined: Wed Mar 23, 2011 6:51 pm
First Name: Roman
Last Name: Petty
Jeep Year: 1991
Jeep Model: XJ (1984–2001 Wagoneer/Cherokee)

Re: the rig is SICK!

Postby rlpetty43 » Tue Jan 08, 2013 12:55 pm

what oil filter are you using not to long ago I had bought an stp oil filter which i got because they had a sale well when I start my xj I had no oil pressure. so I went to investigate and most of my oil was on the pavement the seam weld on the top of the filter was weled properly. I have alos have heard others have trouble with stp filters
91 XJ 5sp 35x12.5 KM2, 4.5" lift, custom bumpers, warn vr8000, 4.88 G2 gears and iron rock truss ford 8.8 rear 31 spline, trussed hp dana 30 with wj knuckle swap and eaton elocker.
"amateur radio call sign AC5XJ"
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Tue Jan 08, 2013 2:25 pm

I used a cheap STP filter and Quakerstate 10w30 and it "seeped" from the gasket.

I went back up to the parts store and got a Fram filter and a quart of 5w30.

It still has no oil pressure with a Fram filter on it, and about 6.5+ quarts of oil in it.

I'm driving the TJ until its fixed, the XJ has an appointment with a car doctor friday
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
User avatar
jjstasen
Posts: 922
Joined: Thu Dec 24, 2009 9:27 pm
First Name: Josh
Last Name: Stasen
Jeep Year: 2008
Jeep Model: Other "non Jeep"
Location: okc ok

Re: the rig is SICK!

Postby jjstasen » Thu Jan 10, 2013 6:31 pm

down 1 jeep :( :( :( :(

sold the rig
99 XJ classic, 3 link front, 4 link rear, 35''s SOLD
99 XJ sport, 3" lift, 31's SOLD
AKA Nut Gobbler
ghostrider
Posts: 18
Joined: Fri Oct 03, 2014 11:38 am
First Name: Don
Last Name: Gurley
Jeep Year: 2000
Jeep Model: XJ (1984–2001 Wagoneer/Cherokee)

Re: the rig is SICK!

Postby ghostrider » Mon Oct 06, 2014 1:40 pm

I had the same problem with my 2000 XJ Cherokee after I bought it . The main bearings were going out. I had them replaced, but the same thing happened when I picked it up. I ended up having to rebuild my motor due to imcompotent mechanic and Harold Garage in Harah. Heres what was found. The pick up tube connected to the oil pump wasn't cleaned out the first time the bearing were changed. Fortunately for me, the rebuild kit came with a new oil bump and pick up tube. The oil pump is attached to the bottom of the motor and the pick up tube is attached to the oil pump. The tube as you know, supplies oil from the oil pan and goes throught the pump. You can do this your self. Buy and pan gasket and a tube of ULTRA BLUE before starting. It's easy to do with some model and depending on if you have a lift or having to do laying on the ground. Definitley chain the oil and filter. Check to see fit he pick up tube is clogged. It may be full of metal shavings. If this is what you find, then you may need to replace the main bearing. In this case, you will need to buy a new oil pump. Good luck and hope this helps.
ghostrider
Posts: 18
Joined: Fri Oct 03, 2014 11:38 am
First Name: Don
Last Name: Gurley
Jeep Year: 2000
Jeep Model: XJ (1984–2001 Wagoneer/Cherokee)

Re: the rig is SICK!

Postby ghostrider » Mon Mar 02, 2015 7:03 pm

Try another oil filter. Your oil pick up screen may be clogged. Drop the pan and check. If there is metal shavings like happened to mine, the main bearings may need replacing sand the pick up tube replaced or cleaned. Good luck.
Shrek
Posts: 392
Joined: Thu Jan 12, 2012 6:39 pm
First Name: Danny
Last Name: Hubers
Jeep Year: 2012
Jeep Model: JK (2007–2019 Wrangler)
Location: noble

Re: the rig is SICK!

Postby Shrek » Mon Mar 02, 2015 11:19 pm

You keep posting on old news ?
2012 jku Rubicon, 3.5 metal cloak game changer lift, evo skids, 35" nitto trail grapplers.
Procrastinator
Posts: 225
Joined: Mon Dec 14, 2009 4:34 pm
First Name: Tyrannosaurus
Last Name: Tex
Jeep Year: 2007
Jeep Model: JK (2007–2019 Wrangler)

Re: the rig is SICK!

Postby Procrastinator » Tue Mar 03, 2015 5:57 pm

This guy...

Return to “Compact Stuff”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest